TG589 router - Fixing problems with the lights

None of the LEDs light up (TG589 router does not work)

Make sure that:

  • the TG589 router is plugged into a power socket outlet
  • you’re using the correct power supply for your TG589 router device
    The power requirements for your TG589 router are clearly indicated on the identification label of the TG589 router. Only use the power supply unit that is supplied with your TG589 router
  • the TG589 router is turned on via the push button or rocker switch on the back panel

The Broadband LED does not light up or is blinking

Make sure that:

  • the DSL cable is correctly connected
  • the DSL service is enabled on your telephone line. For more information, contact your Internet Service Provider
  • check the Broadband settings on the web interface. Proceed as follows:

    a)    Browse to the TG589 router web interface.
    b)    In the Broadband card header, make sure that the switch is in the position.
    c)    Select Broadband and then show advanced. If you're using the TG589 router as:
       DSL gateway, make sure that ADSL2+ or VDSL is selected. Make sure to select the correct DSL type.
       Local router, make sure that Ethernet is selected.
    d)    Choose Switch connection mode.
    e)    After a few minutes the Status should switch to connected. If needed, click refresh data first.

Ethernet LED does not light up

Make sure that:

  • the Ethernet cable is correctly connected to the Ethernet port on your TG589 router and your computer
  • you’re using the correct cable type for your Ethernet equipment, which is at least UTP CAT5 with RJ-45 connectors

Was this article helpful?

Thank you.

Thank you.

Thank you.

Thank you.

Thank you, now you can press any tab to choose why this article is not helpful.

Your response was sent. Thank you.

Getting the most from EE

Services and offers we have for you