System requirements

Although a PC or Laptop is not required to use this device, in order to configure or use this device via USB connection your PC or laptop must fulfill the following minimum system requirements:

  • Windows XP, Windows Vista, Windows 7, Windows 8,
  • Mac OS X 10.5, 10.6, 10.7 & 10.8 with latest upgrades
  • Hardware system should meet the recommended requirements for the installed OS version
Last updated: 14/9/2018
Simon H posted this. Got a comment? Good or bad, we'd be pleased to hear from you.
Was this article helpful?
How can we improve this article?
    >
  • Please select a reason
  • The article didn't answer my question
  • The article is missing important information
  • I didn't understand the article
  • I found the information but it didn't resolve my issue
  • Please let us know how we can make it better
0/600
Great!

Thanks for your feedback

Thanks for your feedback

We'll use your feedback to keep improving our help articles